Connor McMillan

connor@mcmillan.website – http://github.com/mibs510

Issue with QT_QPA_PLATFORM on Ubuntu 17.04 Zesty

Recently I upgraded from Ubuntu 16.04 to 16.10 and then to 17.04. Along the way to Zesty, neither Qt Creator or Virtualbox would start as a normal user but would upon executing it as root.

"Unable to select module, using null backend.
Segmentation fault (core dumped)"

"This application failed to start because it could not find or load the Qt platform plugin "ubuntumirclient"
in "".

Available platform plugins are: minimal, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)"

After digging around I noticed that in my env QT_QPA_PLATFORM was set to ubuntumirclient which was already hinting an obvious fix. Change the value of QT_QPA_PLATFORM to xcb so:

$ export QT_QPA_PLATFORM=xcb

DROP A COMMENT

Your email address will not be published. Required fields are marked *